Hoàng Luyến

Hoàng Luyến

Administrator

Hỏi cách xử lý lỗi Joomla 1.5.x chạy trên PHP 5.4.x?


Bài viết nằm trong Series Hỏi đáp Xampp

Trả lời câu hỏi tuần 4 tháng 7/2015 của bạn đọc về cách sửa lỗi Joomla 1.5.x chạy trên PHP 5.4.x.

Bạn đọc hỏi: Chào anh Hoàng Luyến. Anh có thể hướng dẫn cho e cách sửa lỗi Joomla 1.5.x chạy trên PHP 5.4.x khi nâng cấp Xampp được không ak?

Trả lời câu hỏi:

Chào bạn đọc. Khi bạn nâng cấp chạy xampp lên phiên bản cao hơn chạy php 5.4.x thì joomla 1.5.x sẽ bị lỗi. Còn nếu cài joomla 1.5.x lên hosting chạy PHP 5.4.x thì sẽ hiển thị lỗi trang trắng tinh. Nguyên nhân là do Joomla 1.5.x chỉ chạy được trên phiên bản PHP nhỏ hơn 5.4. Cách xử lý để Joomla 1.5.x chạy được trên phiên bản PHP 5.4.x mình sẽ hướng dẫn bạn 2 trướng hợp như sau:

1) Chạy trên localhost:

Khi bạn cài Xampp với phiên bản cao hơn thì nó sẽ chạy với phiên bản PHP từ 5.4.x trở lên. Vì vậy các web chạy Joomla 1.5.x sẽ không tương thich phiên bản và hiển thị đống lỗi. Khi gặp điều này, bạn muốn khắc phục thì hãy truy cập đường dẫn xampp/php mở file php.ini trong thư mục PHP sau đó tiến hành đổi:

  • error_reporting = E_ALL | E_STRICT => error_reporting = E_ALL & ~ E_STRICT
  • display_errors = On => display_errors = Off

Sau khi tiến hành đổi thành công thì bạn hãy lưu lại file, tắt Xampp và chú ý phải thoát hoàn toàn nhé. Để chắc chắn hơn thì nên tắt máy tính rồi mở lại (tất nhiên mở lại thì Xampp, Wamp,.. cũng không được đang ở trạng thái tự động mở) và khởi động lại Xampp. Lúc này bạn thử mở một phiên bản Joomla 1.5.x xem kết quả nhé.

* Lưu ý: Bạn vẫn có thể chạy được Joomla 1.5.x, nhưng trong một số trường hợp vẫn hiển thị lỗi hoặc hiển thị trang trắng. Nguyên nhân là do trong đoạn code bạn sử dụng có chứa một số hàm mà không được hỗ trợ trên PHP 5.4.x. Lúc này bạn cần xóa từng dòng code để kiểm tra xem cụ thể là hàm nào bị lỗi và xóa nó đi.

2) Chạy trên Server Hosting:

Trường hợp này chúng ta không thể mở được file php.ini để sửa được. Bạn có thể làm theo cách sau:

a) Sửa file .htaccess: Thêm đoạn mã sau vào file .htaccess

hoặc thử với đoạn mã này:

b) Sửa file configuration.php: Thay đổi giá trị var $error_reporting = ‘-1’; thành var $error_reporting = ‘6135’;

Nếu bạn thử mà không được thì có thể làm theo cách này nữa:

– Đăng nhập trang quản trị: Site >> Global Configuration >> Server >> Error Reporting: Chọn Maximum
– Hoặc có thể điều chỉnh trong file configuration.php của mã nguồn, cấu hình biến $error_reporting sử dụng các giá trị sau:

-1: Tắt thông báo lỗi
30709: Hiển thị tất cả các lỗi ngoại trừ warnings và notices (cấu hình tương đương E_ALL & ~(E_NOTICE|E_WARNING) )
30711: Hiển thị tất cả các lỗi bao gồm warnings, không bao gồm notices (cấu hình tương đương  E_ALL & ~E_NOTICE )
30719: Hiển thị tất cả các lỗi bao gồm warnings và notices, không bao gồm E_STRIC (cấu hình tương đương  E_ALL &~ E_STRIC)
32767: Hiển thị tất cả các lỗi, warning, notices và các lỗi “strict standards” (ví dụ:  “Strict Standards: Non-static method … on line XX”) (cấu hình tương đương E_ALL )
– Với mục đích kiểm tra lỗi liên quan đến phiên bản PHP, phần cấu hình này nên sử dụng giá trị 32767  để hiển thị tất cả các lỗi bao gồm gợi ý của PHP về việc các hàm mà mã nguồn đang sử dụng có tương thích / phù hợp với phiên bản PHP mà hệ thống đang sử dụng hay không.
 Ví dụ:
public $error_reporting = ‘32767:’;

public $log_path = ‘/home/xxx/public_html/joomla/logs’; #Đường dẫn lưu file log

– Tùy thuộc vào phiên bản PHP máy chủ đang sử dụng mà cấu hình hiển thị tất cả các lỗi E_ALL khác nhau như sau:

32767 nếu là PHP 5.4.x trở lên
30719 nếu là PHP 5.3.x
6143 nếu là PHP 5.2.x
2047 nếu là các phiên bản PHP thấp hơn

 Tới đây chắc bạn cũng hiểu cách của mình. Bạn thử xem thế nào nhé. Nếu vẫn không được thì hãy PM cho mình, mình sẽ tìm ra hướng giải quyết khác. Thân ái!

Một số bài viết liên quan tới lỗi PHP Xampp mà bạn có thể tìm hiểu:

Nếu bạn có những ý kiến đóng góp nào khác về cách sửa lỗi Joomla 1.5.x chạy trên PHP 5.4.x xin hãy để lời bình luận phía dưới để giúp bạn đọc biết cách xử lý tình huống này. Cảm ơn bạn đọc đã ghé thăm Blog Hoàng Luyến.

Hướng dẫn cách cài đặt Xampp

 Hỏi cách sửa lỗi Joomla 1.5.x chạy trên PHP 5.4.x?

Ảnh. Hỏi cách sửa lỗi Joomla 1.5.x chạy trên PHP 5.4.x?


Thông tin chính của bài viết: cach sua loi Joomla 1.5.x chay tren PHP 5.4.x, cach xu ly, nâng cấp xampp, Joomla 1.5.x chạy trên PHP 5.4.x, sửa lỗi, fix lỗi, help lỗi, lỗi thường gặp, lỗi hay gặp, lỗi phổ biến, cách xử lý lỗi, tình huống lỗi, giải quyết lỗi, khắc phục lỗi, cài xampp bị lỗi, wordpress tiếng việt, hỏi đáp wordpress, loi thuong gap, loi hay gap, loi pho bien, cach xu ly loi, giai quyet loi, tinh huong loi, khac phuc loi, lỗi reset xampp, error, lỗi cài đặt xampp, restart xampp, start xampp, port 80, cong 80, cài xampp, apache, mysql, database, connection, localhost, phpmyadmin, hỏi đáp máy chủ, máy chủ, server, vps, thủ thuật wordpress, thủ thuật seo, thủ thuật web, thủ thuật wp


 WordPress Tiếng Việt  »  Hoc WordPress   »   Sử dụng WordPress »  Hỏi đáp WordPress

Hỏi cách xử lý lỗi Joomla 1.5.x chạy trên PHP 5.4.x?
Đánh giá bài viết


Viết bình luận

Tất cả bình luận

Thật tuyệt vời nếu bài viết này nhận được ý kiến của bạn. *

SEO